PHP Selector CloudLinux выбор версии PHP

Официальная документация: http://docs.cloudlinux.com/

Включить CageFS

# cagefsctl --enable user253696
# cagefsctl --force update


Посмотреть какие PHP есть

# cl-selector --list=php

Включить PHP нужной версии

# cl-selector --select=php --version 5.3 --user user2536967

Добавить расширение глобально (почему-то для существующих не добавляет даже force update)

# selectorctl --enable-extensions=zend_optimizer --version=5.2


Посмотреть какие расширения есть

# cl-selector --list-extensions=php --version 5.2

Включить для юзера

# selectorctl --enable-user-extensions=zend_optimizer --version=5.2 --user=user2533184


Изменяем какое-либо значение для пользователя
/usr/bin/piniset -r 'magic_quotes_gpc:off' -u user2536967

Если такое не срабатывает с ошибкой вида
ERROR:No ‘apc.shm_size’ option in white list!
то можно назначать редактированием файла конфига из под юзера по ssh:

su userXXXX
bash-4.1$ php --ini|grep parsed
Additional .ini files parsed: /opt/alt/php54/etc/php.d/alt_php.ini

vi /opt/alt/php54/etc/php.d/alt_php.ini

Комментариев нет:

Отправка комментария